登录
  • #机器学习

【求助】难道用2060就跑不了TensorFlow 1吗!

VincentRow
798
10
最近在搭深度学习环境,要完成一个课设,需要用tensorflow-gpu 1.15训练模型。我按照tensorflow官网的版本对应安装了CUDA 10.0 和cuDNN 7.4,环境变量添加了,测试tf.test.is_gpu_available()也是通过,但一开始训练的时候就报这个错:

F tensorflow/stream_executor/cuda/cuda_driver.cc:175] Check failed: err == cudaSuccess || err == cudaErrorInvalidValue Unexpected CUDA error: invalid argument

我的gpu是2060,驱动是r456.71. 按理来说高版本驱动应该都能兼容低版本的吧(CUDA10.0要求的是418以上貌似)





就很气啊,我tensorflow-gpu 2.2 的环境搭好了也可以训练模型了,唯独TF 1代的就不行,查遍百度谷歌都没有有效的解决办法,github貌似也没什么人遇到这个问题。。所以最后来地里挣扎一下,希望好心人大佬可以给点建议!谢谢!!有用的建议会加米!





PS 其实之前已经换TF cpu花了几十个小时把模型训练完了,但现在需要摄像头实时识别测试模型,cpu版只能调用核显,画面卡得一匹完全幻灯片,而且due马上到了,仍然不死心才来地里再挣扎一下,实在解决不了就算了吧反正也不会影响我最后的分数了,主要还是心里气不过………………
10条回复
热度排序

发表回复